Consistent crashing before loading Relto

Post Reply
Zapoteca
Posts: 6
Joined: Thu Aug 15, 2019 6:06 am

Consistent crashing before loading Relto

Post by Zapoteca » Sat Mar 27, 2021 3:12 am

I'm trying to run Destiny with files copied from a shining new MOULa install. I can create avatars, but I always crash before the first link to Relto, precisely at this point
destiny.png
destiny.png (4.59 KiB) Viewed 1589 times
I have the VS2019 C++ redistributable, and the shortcut is using the -LocalData flag

Any suggestions? Do I need older files?

Zapoteca
Posts: 6
Joined: Thu Aug 15, 2019 6:06 am

Re: Consistent crashing before loading Relto

Post by Zapoteca » Sat Mar 27, 2021 5:02 pm

I tried compiling the client from the repo, but now I simply get a black screen before reaching the character selection screen

User avatar
Mystler
Administrator
Posts: 51
Joined: Tue Jan 22, 2013 2:25 pm
Location: Germany
Contact:

Re: Consistent crashing before loading Relto

Post by Mystler » Sun Mar 28, 2021 2:04 pm

Did you try it with the precompiled client posted here?

Zapoteca
Posts: 6
Joined: Thu Aug 15, 2019 6:06 am

Re: Consistent crashing before loading Relto

Post by Zapoteca » Wed Apr 07, 2021 3:55 am

Yes, that's the first one I tried. When it failed, I tried different combinations of pre-compiled h'uru clients and data files from the moul-assets repo, but the the error reported on the first post is as far as I can possibly get

I'm not the only one, as the same issue was reported in this post:

viewtopic.php?p=130#p130

Zapoteca
Posts: 6
Joined: Thu Aug 15, 2019 6:06 am

Re: Consistent crashing before loading Relto

Post by Zapoteca » Thu Apr 08, 2021 12:19 am

OK, finally figured it out.

I tried using another machine.

First attempt: fresh MOULa avi+dat+sfx files, plus the client posted here on this forum. Result: wouldn't even get to the login screen due to some missing dll

Second attempt: MOULa datafiles, plus the newest client from the h'uru github. Result: crashed exactly where it was crashing on the other machine, but this time I got a more helpful error message, stating it was a problem with SDL

Final, successfull attempt: MOULa datafiles, plus the newest client from the h'uru github SANS the SDL folder, plus the SDL folder from the client posted in this forum. Result: everything's a-go!

EDIT:
Another useful detail: after successfully getting to Relto on the other machine, the Destiny installation on the first machine now works as well, with no changes needed. So I guess this is why this issue was only affecting new users, since it's completely tied to the StartupHelpGUI

User avatar
Mystler
Administrator
Posts: 51
Joined: Tue Jan 22, 2013 2:25 pm
Location: Germany
Contact:

Re: Consistent crashing before loading Relto

Post by Mystler » Fri Apr 09, 2021 11:17 am

Good catch! I'll look into updating the precompiled client instructions with a cutting edge option to use the H'uru CI. I've been waiting for automated builds for a while. It's nice to have them available now.

Post Reply